Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Forum Statistics
» Members: 7,939
» Latest member: iptv19
» Forum threads: 1,597
» Forum posts: 8,066

Full Statistics

Online Users
There are currently 24 online users.
» 1 Member(s) | 23 Guest(s)

Latest Threads
Forum: General Android Apps
Last Post: iptv19
1 hour ago
» Replies: 0
» Views: 4
Mecool KIII pro hdmi outp...
Forum: MECOOL TV Boxes
Last Post: gatos814
2 hours ago
» Replies: 15
» Views: 190
(CUSTOM ROM) Nexbox A1/Le...
Forum: NEXBOX A1 (S912, Android 6.0)
Last Post: gatos814
10-16-2018, 12:11 PM
» Replies: 7
» Views: 259
!!!! NEED HELP !!! Can I ...
Forum: MECOOL TV Boxes
Last Post: gatos814
10-14-2018, 10:04 PM
» Replies: 1
» Views: 56
Mecool M8S PLUS L Firmwar...
Forum: MECOOL TV Boxes
Last Post: gatos814
10-14-2018, 09:52 PM
» Replies: 1
» Views: 32
Nexbox no sound
Forum: NEXBOX A1 (S912, Android 6.0)
Last Post: gatos814
10-14-2018, 07:45 PM
» Replies: 9
» Views: 194
M8S Pro W Questions
Forum: MECOOL TV Boxes
Last Post: gregeeh
10-13-2018, 02:05 AM
» Replies: 0
» Views: 36
You tube
Forum: Alfawise TV Boxes
Last Post: bear79
10-12-2018, 09:12 AM
» Replies: 2
» Views: 59
mecool m8s plus w проблем...
Forum: MECOOL TV Boxes
Last Post: gatos814
10-12-2018, 09:09 AM
» Replies: 1
» Views: 45
Problem on Mecool M8S Plu...
Forum: MECOOL TV Boxes
Last Post: Revum34
10-10-2018, 04:58 PM
» Replies: 0
» Views: 44

Posted by: iptv19 - 1 hour ago - Forum: General Android Apps - No Replies

Application 1
Application 2

App TV

TV latino app


Sstv app

Print this item

  Mecool M8S PLUS L Firmware needed
Posted by: mcoolfrk - 10-14-2018, 08:42 PM - Forum: MECOOL TV Boxes - Replies (1)

I have bricked my device and cant find any firmware for it. If you have please share the firmware. Also please give some instruction how to flash it, I am new to this!

Print this item

  M8S Pro W Questions
Posted by: gregeeh - 10-13-2018, 02:05 AM - Forum: MECOOL TV Boxes - No Replies

Hi all,

Just purchased a M8S Pro W and have a couple of questions.

1. I cannot turn the box back ON with the remote once it has been OFF for more then about 30 seconds.  Makes no difference what one of the PowerKey Definitions I select.

2. Voice does not work at all.  I can press the button on the remote and the screen changes, but it does not react to anything I say.  It's just like I said nothing.



Print this item

  !!!! NEED HELP !!! Can I Upgrade my MECOOL BB2 PRO?
Posted by: rangsan - 10-13-2018, 01:29 AM - Forum: MECOOL TV Boxes - Replies (1)

Can I Upgrade My MECOOL BB2 PRO From Android 6.0 to Android 7.1.1?
If I Can Please Give Me The URL For Download Android 7.1.1 Firmware.

Thak You

Print this item

Photo mecool m8s plus w проблема с загрузкой
Posted by: boysyaboy - 10-12-2018, 07:58 AM - Forum: MECOOL TV Boxes - Replies (1)

В моем новом mecool m8s plus w проблема следующего характера, сразу после загрузки пусковой установки (1-2 секунды), программа тестирования (китайский) включена и как выйти из нее неясно. Помогите с советом !! [Image: folderview?id=1X6tC32mFzxP86TAKFhvNUvXblRAabA1k]https://drive.google.com/folderview?id=1...XblRAabA1k

Print this item

  You tube
Posted by: bear79 - 10-11-2018, 04:46 PM - Forum: Alfawise TV Boxes - Replies (2)

I need the preinstalled you tube apk for h96 pro plus 7.1 android.
Does anyone has it?

Print this item

  Problem on Mecool M8S Plus DVB-T2 when recording with DTV application
Posted by: Revum34 - 10-10-2018, 04:58 PM - Forum: MECOOL TV Boxes - No Replies


I recently purchased a Mecool M8S Plus DVB-T2 TV Box.
The DTV Application is not reliable when recording programs.
This a problem with the management of the .ts files containing the records.
RMC 153001.ts  = 0 Bytes
RMC 153001.ts0 = 0 Bytes
RMC 153001.ts1 = .705 GB
Part of the recorded program is missing.

When there are several recorded programs, some are correct (ex: record splitted into 2 files i.e. *.ts and *ts0)

Recording is done on an USB key 32GB formatted in FAT32.

The DTV App is Version 1.0 (th.dtv)
I could not find a more recent version.

Did one of you experience the same problem ?
Where could I find a new version if any ?

Thanks for you help

Print this item

  Mecool KIII pro hdmi output failure
Posted by: Danube1910 - 10-10-2018, 08:28 AM - Forum: MECOOL TV Boxes - Replies (15)

Hi, I am a user of K3 pro device since one year. I am very glad to have a nice device. Last week when I saw a new firmware update, I tried to install this one. But it failed cos I tried this via usb stick. It gives me a E3004 error. Then I tried to flash via usb burning tool with pc. My mecool screen has gone. I connected box to Laptop via usb cable. I flashed this device four times. Every time it gave no screen via hdmi connection. Box give me signal via AV cable. I tried to change all hdmi port of my tv and also different tv port. Nothing changed and no hdmi signal. What can I do for this fault?? Please urgent help..

Print this item

Sad MECOOL M8S PRO PLUS Amlogic S905W with voice control
Posted by: sashabravie - 10-06-2018, 01:45 PM - Forum: MECOOL TV Boxes - Replies (1)

Hello! Could somebody send firmware(img file) for this console? Huh Huh Huh

Attached Files Thumbnail(s)
Print this item

  Problems with Wosung NC 95-X
Posted by: AgustinH88 - 10-05-2018, 01:26 AM - Forum: General - Guides and FAQ - Replies (6)

Hello to all! I just buyed today the Wosung TV BOX with this specs,

Mini Android TV box: 3.74 x 3.74 x 0.55 inche
Android OS: Android 6.0.1 OS
CPU: Amlogic S905X Quad Core A53 2.0 GHz
GPU: Penta-core Mali-450MP 
Memory size: 8GB EMMC Flash 
WIFI: 802.11 b/g/n
Image Browser: Support JPEG、BMP、GIF、PNG 
Remote Control: Support phone control, 2.4GHZ wireless mouse/Remote controller

The thing is I have two problems, one of them MAJOR:

MAJOR: Is impossible to install any app, just a few, everything just says that I can't install because my device is not compatible with the app (and I'm saying like Nova Launcher...). I updated Play Services, tried to update Play Store but just crash and stay in the same version. I deleted cache, data, turn off and turn on the devices and nothing happens...in an app to get notify if I can receive updates of play services just say that it isn't installed or it is incomplete. Please help!

Print this item

TV Box News