Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A95X 2g/8g Boot Loop
#1
First post, bear with me.

Purchased new Nexbox A95X 2g/8g. On first boot, splash screen (Nexbox A95x Logo) appears, then the animated Nexbox logo appears. Stays on this logo until the animation freezes and box no longer does anything. I left the box for 30 minutes with no change.

Rebooted box, same result. Pressed reset button, entered android recovery, and did factory reset.

Reboot after reset, same result, only now the box will boot, gets to animated logo, then reboots. Eventually, the screen will go blank.

I have reflashed firmware with the original android 6, flashed with android 7 as well with the same results. I installed libreelec 8.2.3 to an SD Card and it will boot from SD-Card.

I understand that the power supply may be the issue with booting to Android, as I assume Libreelec on sd uses less power.

Since I don't have another power cable to try, I'm looking for any other possibilities before I attempt to find a compatible power supply locally.

Thanks in advance.
Reply
IPVanish is probably the best VPN service to use in order to watch movies and TV shows anonymously on Kodi or otherwise. And, Xiaomi is gettting popular in the world.
#2
As you said yourself first look for a similar power adapter and when you know that this is working ok then start to find other ''working'' parameters....!
Good luck!
Reply
#3
Well, it does appear that the power supply that came with the device is under powered. I was able to boot using a USB male to male cable and a 2amp tablet charger and it boots the first time, every time. Does use up one of the two ports on the box, but I guess that is what USB hubs are for!
Reply
#4
So you have your answer....!
Go for a new power adapter from 2A and above!
Or even better , talk with the seller for resending you a good power adapter!
Regards
Reply
IPVanish is probably the best VPN service to use in order to watch movies and TV shows anonymously on Kodi or otherwise. And, Xiaomi is gettting popular in the world.


Forum Jump:


Users browsing this thread: 1 Guest(s)
TV Box News