Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
A95X S905X 1/8 not working after flashing (not bricked)
#1
Hi,

I have a A95X S905X 1/8.

It was working fine, until I tried to flash it with the SD card method, but it became non-responsive.

Since then, when I plug the power both blue and red lights are on, but no signal on TV.

Then I tried the USB flashing tool.

The box is instantly recognized by the tool, but, 2 different usb cables, 2 different PCs, 4 different versions of the tool and 6 different firmwares - everytime I get the 2% error.

I've read numerous posts, tried a lot of combinations, no success. Any ideas?

Thanks!

Most probably it's the same issue that this guy mentions here

He mentioned that the managed to fix it with the "stock" rom.

Do you maybe know which exactly is this rom?
Reply
IPVanish is probably the best VPN service to use in order to watch movies and TV shows anonymously on Kodi or otherwise. And, Check GearBest $12 Sale (including many TV Boxes and Smartphones!)
#2
After downloading more than 10 additional files, I managed to find the correct firmware, box is up and running again!

In case someone needs it in the future, unfortunately I didn't keep the link, but the image name is cyx_NEXBOX-A95X_8189etv_8g1g_kodi_addons_160628_USB.img
Reply
#3
If all was installed ok on windows and you have the proper firmware for your tv box you will never never have any problem at all!
Regards

Wink
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
TV Box News